Camera Basics

There are two types of cameras in NUBIGON: perspective and orthographic. Use the Perspective and Orthographic buttons in the View menu to switch between camera modes.

To view and edit camera settings (e.g., near and far plane), select the default scene item persp or ortho in the Object List, and then go to Object Inspector > Object Attributes.

Predefined Camera Views

Select one or more objects of interest and choose a view under View > Predefined Camera Views. This orients the current camera along the chosen predefined direction and adjusts the camera position to focus on selected objects. In the orbit navigation mode, this will also set the rotation center to the center of the selected objects.

Camera Tools

View > Camera Tools > Set Bookmark

Saves the camera viewpoint for the current session.

View > Camera Tools > Show Bookmark

Restores previously saved camera viewpoint.

View > Camera Tools > Focus

This is another button for the top view (Shortcut: F).

View > Camera Tools > Align

This tool is useful for focusing on specific regions in the viewport. Activating this tool will change the mouse cursor to a crosshair for picking three points in the viewport. The triangle defined by the chosen points will define the orientation and position of the current camera. In the orbit navigation mode, the triangle center will become the rotation center.

View > Camera Tools > Reset  

Sets the camera viewpoint to its default, and the camera rotation center to the origin.

View > Camera Tools > Set Pivot  

In the orbit navigation mode, this operation sets the camera rotation center to a user-defined point in the viewport.

TIP: You can use Align and Set Pivot with snapping tools.

Was This Article Helpful?

0
0 Comments

There are no comments yet

Leave a comment

Your email address will not be published.