Curve Editing

This article introduces how to edit different types of curves in NUBIGON. Curves can be edited both in the viewport and the Object Inspector. 

Editing on the Viewport

Tools > CAD > Curve Editing

To enable curve editing directly on the viewport, click the Curve Editing icon or use the command in the Tools Menu. When curve editing is enabled, curve control points will appear.

Polyline

  • Left-click and drag polyline vertices to move them.
  • Right-click on a polyline vertex to delete it.
  • Right-click on a polyline edge to insert a new vertex.
  • Close an open polyline by dragging and dropping the endpoint onto the first point. You need to enable Snap to CAD before closing a polyline.

Arc

  • To reshape an arc, left-click and drag its mid- and endpoints.
  • Left-click and drag an arc to change its radius.
  • Left-click and drag the center of an arc to move the arc on its supporting plane.

Circle

  • Left-click and drag a circle to change its radius.
  • Left-click and drag the center of a circle to move the circle on its supporting plane.

Compound Curve

You can edit a compound curve by editing its sub-curves. We support all arc, and polyline editing operations described above. It’s not permitted to delete joining vertices of sub-curves. 

Editing in the Object Inspector

Polylines, arcs, circles, and points can be edited in the Object Inspector. The properties of the selected object are shown in the Object Inspector.

Polyline

You can change coordinates of polyline vertices and adjust edge lengths.

TIP: Coordinates of a 2D polyline cannot be arbitrarily changed. Only changes that maintain the planarity of 2D polylines are allowed.

Arc

You can change the center point, radius, and angle of an arc.

Circle

You can also change the center point and radius of a circle.

Point

Use the Location property of a point to change its coordinates.

More Curve Editing

Join

Tools > CAD > Join

Use this command to combine a sequence of polylines and arcs that touch end to end. Joining only polylines creates another polyline. A set of curves containing at least one arc is joined to a compound curve.

Explode

Tools > CAD > Explode

Use this command to split a compound curve into its sub-curves or a polyline into a sequence of line segments.

Reverse

Tools > CAD > Reverse

Use this command to reverse the direction of selected curves.

TIP: Visualization of curve directions can be toggled through Edit > Preferences > Settings > Curve direction.

Was This Article Helpful?

0
0 Comments

There are no comments yet

Leave a comment

Your email address will not be published. Required fields are marked *